Kubernetes Compatibility

Cilium is compatible with multiple Kubernetes API Groups. Some are deprecated or beta, and may only be available in specific versions of Kubernetes.

All Kubernetes versions listed are e2e tested and guaranteed to be compatible with Cilium. Older Kubernetes versions not listed in this table do not have Cilium support. Newer Kubernetes versions, while not listed, will depend on the backward compatibility offered by Kubernetes.

k8s Version k8s NetworkPolicy API CiliumNetworkPolicy
1.12, 1.13, 1.14, 1.15, 1.16, 1.17, 1.18, 1.19 cilium.io/v2 has a CustomResourceDefinition

Cilium CRD schema validation

Cilium uses a CRD for its Network Policies in Kubernetes. This CRD might have changes in its schema validation, which allows it to verify the correctness of a Cilium Clusterwide Network Policy (CCNP) or a Cilium Network Policy (CNP).

The CRD itself has an annotation, io.cilium.k8s.crd.schema.version, with the schema definition version. By default, Cilium automatically updates the CRD, and its validation, with a newer one.

The following table lists all Cilium versions and their expected schema validation version:

Cilium Version CNP and CCNP Schema Version
v1.6.0-rc1 1.14
v1.6.0-rc2 1.14
v1.6.0-rc3 1.14
v1.6.0-rc4 1.14
v1.6.0-rc5 1.14
v1.6.0-rc6 1.14
v1.6.0-rc7 1.14
v1.6.0 1.14
v1.6.1 1.14
v1.6.2 1.14
v1.6.3 1.14
v1.6.4 1.14
v1.6.5 1.14
v1.6.6 1.14
v1.6.7 1.14
v1.6.8 1.14
v1.6.9 1.15
v1.6.10 1.15
v1.6.11 1.15.1
v1.6.12 1.15.1
v1.6 1.15.1
v1.7.0-rc1 1.15
v1.7.0-rc2 1.16
v1.7.0-rc3 1.16
v1.7.0-rc4 1.16
v1.7.0 1.16
v1.7.1 1.16
v1.7.2 1.17
v1.7.3 1.17
v1.7.4 1.17
v1.7.5 1.17
v1.7.6 1.18
v1.7.7 1.18.1
v1.7.8 1.18.1
v1.7.9 1.18.1
v1.7.10 1.18.1
v1.7.11 1.18.1
v1.7 1.18.1
v1.8.0-rc1 1.19
v1.8.0-rc2 1.20
v1.8.0-rc3 1.20
v1.8.0-rc4 1.20
v1.8.0 1.21
v1.8.1 1.21
v1.8.2 1.21.1
v1.8.3 1.21.1
v1.8.4 1.21.2
v1.8.5 1.21.2
v1.8 1.21.2
v1.9.0-rc0 1.22.1
v1.9.0-rc1 1.22.2
v1.9.0-rc2 1.22.2
v1.9.0-rc3 1.22.3
v1.9.0 1.22.3
v1.9 1.22.3
latest / master 1.22.3